Brad Fitzpatrick (brad) wrote in fotobilder,
Brad Fitzpatrick
brad
fotobilder

Obscure bug fixed

For the last couple days it's been bugging me that everything was working on my own machine, but not on picpix.com, where most people were testing stuff.

I attributed it to inconsistent state in the database, due to old buggy code, so I wrote those two integrity checking pages.

But, that didn't do it... I still found cases where things worked here but not on the public site.

I traced it to a difference in behavior between the DBI and/or MySQL version I have at home versus there. In all fairness, the behavior change was on a weird corner case (essentially a FB bug: I wasn't trying to rely on the weird results), so it doesn't really matter.... I fixed the bug, and now picpix.com works like it should.

Test away! (but clean your data first with the tools linked off the management page)
Subscribe

  • 302: lj_dev

    In the interests of consolidating all FotoBilder development-related discussion, we're going to be closing down this community. The same…

  • Development stalled?

    Is the development of Fotobilder held? Stalled? I am asking because there is no activity on the community and there is no link to the Fotobilder…

  • (no subject)

    Does FotoBilder works with Apache2? I installed all the required modules on my debian sarge, and when I restart my apache server, it dies horribly…

  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic
  • 4 comments